Acer newTouch

Forum sur le Acer newTouch, neoTouch, F1, S200
 
AccueilFAQCalendrierRechercherMembresGroupesS'enregistrerConnexion

Partagez | 
 

 Solution au probleme de son

Voir le sujet précédent Voir le sujet suivant Aller en bas 
Aller à la page : 1, 2, 3  Suivant
AuteurMessage
seb.c_38
Petit posteur
Petit posteur


Messages : 14
Date d'inscription : 18/01/2010
Localisation : Grenoble

MessageSujet: Solution au probleme de son   Lun 18 Jan - 12:13

Bonjour a tous,

Voila la solution au probleme de son rencontre par de nombreuses personnes.
(Mise a jour du 8 Fev 2010 : Voire version2 plus bas)

description du probleme: Plus de son et plus de micro lors des appels.
Plus de sonnerie non plus lors d'appel entrant.
Plus de son dans les players.

Le 'Workaround' pour les appels etait d'utiliser le HP ou le kit main libre.


+ 'Resolution' du probleme (version 1):

Telecharger un editeur de Registre, puis aller dans:

HKLM/Software/ACER/Scenario

Modifier la cle HeadSetIn de 1 vers 0


+ 'Resolution' du probleme (version 2):

j'ai realise un petit script qui permet d'activer/desactiver le son et de le renvoyer ou non vers les ecouteurs. Me contacter en MP car je ne vois pas inserer de .zip dans le message.

Prerequis: Mortscript v4 (livre avec d'autres cab d'ahitude, mais j'ai une copie si besoin)

Extraire le fichier zip dans le repertoire MortScript.

Cliquer sur HeadSet pour activer/desactiver le son.

Pour rendre ceci plus agreable, j'ai affecte l'action a un des boutons en facade.
Pour cela:

1-Creer un lien dans:
/Windows/Menu Demarrer/Programmes

2- Aller dans
Demarrer/Parametres/Personnel/Bouttons

3- Selectionner Boutton 1 (le Carre en facade) ou Boutton 2 (la fleche a gauche)
buis en bas, chercher HeadSet


Bonne Journee.

Seb.


Dernière édition par seb.c_38 le Lun 8 Fév - 13:35, édité 1 fois
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
darky35
Méga posteur
Méga posteur


Messages : 671
Date d'inscription : 01/01/2010
Age : 45
Localisation : Bretagne

MessageSujet: Re: Solution au probleme de son   Lun 18 Jan - 12:46

Merci seb

pour ce qui on ce probleme merci de tester cette soluce et de nous faire part de la resolution du PB ou pas !!!!
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
seb.c_38
Petit posteur
Petit posteur


Messages : 14
Date d'inscription : 18/01/2010
Localisation : Grenoble

MessageSujet: Re: Solution au probleme de son   Lun 18 Jan - 12:51

Salut Darky,

Je viens d'avoir a nouveau le probleme !!!

Je pense que c'est lie a Windows 7 !!

Depuis Decembre, je suis passe de XP (avec Active sync) a Vista san probleme pour le tel.

Mais j'ai installe W7 la semaine derniere et fait mes synchro et probleme.

J'ai remis le son ce matin.
Viens de refaire une synchro, et son re-perdu ...

Je continue mes investigations.

A+

Seb.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
darky35
Méga posteur
Méga posteur


Messages : 671
Date d'inscription : 01/01/2010
Age : 45
Localisation : Bretagne

MessageSujet: Re: Solution au probleme de son   Lun 18 Jan - 13:13

Je suis en windows seven et je n'ai pas ce probleme, et je comprends pas comment windows pourrais agir sur le son du tel .
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
seb.c_38
Petit posteur
Petit posteur


Messages : 14
Date d'inscription : 18/01/2010
Localisation : Grenoble

MessageSujet: Re: Solution au probleme de son   Lun 18 Jan - 13:37

Peut etre ActiveSync de WM6.5 plante.

Ca vient de le faire encore !!!

La cle doit etre mise a 1 car il detecte une connection PC !!!

Seb.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
darky35
Méga posteur
Méga posteur


Messages : 671
Date d'inscription : 01/01/2010
Age : 45
Localisation : Bretagne

MessageSujet: Re: Solution au probleme de son   Lun 18 Jan - 13:42

je viens de verifier lla clé de registre de mon tel

Elle est a 0

Et je n'ai jamis rien modifier a ce niveau
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
KS
Méga posteur
Méga posteur


Messages : 152
Date d'inscription : 10/01/2010
Age : 39
Localisation : STRASBOURG

MessageSujet: Re: Solution au probleme de son   Lun 18 Jan - 15:38

Bonjour à tous!


Quelqu'un a t il un lien afin de téléchargé un éditeur de registre?
Je n'arrive pas à en trouver!!
Merci
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
darky35
Méga posteur
Méga posteur


Messages : 671
Date d'inscription : 01/01/2010
Age : 45
Localisation : Bretagne

MessageSujet: Re: Solution au probleme de son   Lun 18 Jan - 16:03

salut KS,

Allez je suis de bonne humeur !!! Smile

[Vous devez être inscrit et connecté pour voir ce lien]
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
KS
Méga posteur
Méga posteur


Messages : 152
Date d'inscription : 10/01/2010
Age : 39
Localisation : STRASBOURG

MessageSujet: Re: Solution au probleme de son   Lun 18 Jan - 16:12

Sympa à toi darky!! Very Happy
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Marvel
Petit posteur
Petit posteur


Messages : 23
Date d'inscription : 12/01/2010

MessageSujet: Re: Solution au probleme de son   Mer 20 Jan - 10:39

Bonjour à tous.
Voilà je fais également partie des personnes touchées par ce problème depuis quelques jours.
Jusque là je n'avais aucun problème (hormis le niveau sonore relativement bas mais bon ça on le sait tous déjà)
Il a suffit que j'utilise le cable usb pour recharger mon téléphone pour que je n'ai plus du tout de son (à moins d'utiliser des écouteurs)

J'ai testé l'astude de seb.c_38 qui fonctionne et donc modifier dans la base de registre la valeur de la clé concernée (0 au lieu de 1)

Tout fonctionne à nouveau mais le seul problème c'est que cette valeur modifiée ne reste pas, à chaque utilisation du cable usb et donc connexion sur un pc, le problème revient et la clé de registre repasse à 1 Twisted Evil

Je précise bien à nouveau que je n'ai même pas cherché à faire une synchro lorsque c'est arrivé juste rechargé mon s200.

Même s'il y a l'astuce de seb qui fonctionne en partie, ça reste tout de même pénible de devoir modifier le registre à chaque fois.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
seb.c_38
Petit posteur
Petit posteur


Messages : 14
Date d'inscription : 18/01/2010
Localisation : Grenoble

MessageSujet: Re: Solution au probleme de son   Mer 20 Jan - 11:40

Salut Marvel,

Pour info, tu a quelle version de Windows ?


Sinon, je fais le meme constat avec W7 Home Premium.

Des que je me branche en USB, ca saute.

Je vais essayer de faire un mortscript avec lancement rapide depuis Titanium pour remettre la cle a 0.

Pas trop le temps cette semaine, peut etre semaine prochaine.

Je vous tiens au courant.

A+

Seb.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Marvel
Petit posteur
Petit posteur


Messages : 23
Date d'inscription : 12/01/2010

MessageSujet: Re: Solution au probleme de son   Mer 20 Jan - 12:07

Salut Seb
Testé chez moi avec Vista et également du boulot sur un pc tournant sur XP Pro et donc même problème alors que jusque là tout allait bien.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
darky35
Méga posteur
Méga posteur


Messages : 671
Date d'inscription : 01/01/2010
Age : 45
Localisation : Bretagne

MessageSujet: Re: Solution au probleme de son   Mer 20 Jan - 12:17

Entre le moment ou tout marchais et maintenant as tu installé un soft ou fais une manip particuliere ?
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Marvel
Petit posteur
Petit posteur


Messages : 23
Date d'inscription : 12/01/2010

MessageSujet: Re: Solution au probleme de son   Mer 20 Jan - 12:36

non rien de particulier, c'est bien ça qui m'emme... !!!
Les seules applications que j'avais installé dernièrement c'était les deux applis sfr (sfr wifi et sfr mon compte) sinon rien d'autre.

Depuis j'ai fais une restauration totale du téléphone et donc tout supprimé mais ça n'a rien changé, le fait d'avoir rechargé mon téléphone hier par le port usb a modifié à nouveau cette clé et donc plus de son.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
seb.c_38
Petit posteur
Petit posteur


Messages : 14
Date d'inscription : 18/01/2010
Localisation : Grenoble

MessageSujet: Re: Solution au probleme de son   Mer 20 Jan - 13:15

Moi non plus !!!

Pas d'installe depuis Decembre ...

Sinon, la restauration totale n'efface pas toute la ROM !!!!

J'ai meme reflashe hier aprem avec la 2.003 ACER, et des fichiers n'ont pas ete vires !!

Donc flashage inefficace si c'est un truc installe avant.

Seb.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
darky35
Méga posteur
Méga posteur


Messages : 671
Date d'inscription : 01/01/2010
Age : 45
Localisation : Bretagne

MessageSujet: Re: Solution au probleme de son   Mer 20 Jan - 15:52

Ok !!!

La modif de base de registre ce fait lorsque vous branchez vos tel sur le pc avec le cable USB !!

mais es ce que vous etes en ActivaSync ou en mode lecteur de carte

merci de tester les 2 manip de connexion au pc et de verifier si le probleme arrive avec l'une ou l'autre connexion ou les 2 .......
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
jpg1961
Méga posteur
Méga posteur


Messages : 201
Date d'inscription : 09/01/2010

MessageSujet: Re: Solution au probleme de son   Mer 20 Jan - 16:22

seb.c_38 a écrit:
Bonjour a tous,

Voila la solution au probleme de son rencontre par de nombreuses personnes.

description du probleme: Plus de son et plus de micro lors des appels.
Plus de sonnerie non plus lors d'appel entrant.
Plus de son dans les players.
[...]
Resolution du probleme:
Telecharger un editeur de Registre, puis aller dans:
HKLM/Software/ACER/Scenario
Modifier la cle HeadSetIn de 1 vers 0
[...]
Seb.
Bonjour,
Je voudrais faire quelques remarques et je te prie de ne pas les considerer comme une critique.
C'est grace à des gens comme toi, qui n'hésitent pas à fouiller dans leur machine et faire des essais, que bon nombre de problèmes sont résolus.

En l'occurence, ici, je crois que les termes "solutions" et "résolutions" ne sont pas adaptés. Crying or Very sad

L'entree de registre HKLM/Software/ACER/Scenario/HeadSetIn est en quelque sorte une variable d'environnement non persistante positionnée par le système et destinée à être consultée par d'autres pilotes.
Les observations suivantes peuvent être faite sur une ROM stock et un S200 en sans problèmes matériels.


A l'insertion de la prise jack du kit piétons, le pilote gérant cet événement, positionne la variable HeadSetIn à 1.

Au retrait de la prise jack, ce même pilote positionne la variable à 0.

Un autre pilote, (wav:?) utilise cette variable pour savoir où diriger les flux sons. Si HeadSetIn est 1, les sons vont vers la prise jack.... (Bien sur, si d'autres options n'ont pas été activées comme la redirection du son sur le HP externe depuis le dialer).

Si HeadSetIn n'existe pas, cette variable est automatiquement crée par le système dès que le pilote gérant la prise jack est chargé en mémoire (lors d'un reset) ou bien lorsque l'évènement insertion/retrait de la prise jack est actionné.
Si HeadSetIn est forcée manuellement à "1", elle est automatiquement repositionné à 0 au chargement du pilote (reset) ou éventuellement par suite de l'événement retrait de la prise.

Une autre observation peut être faite. Si lors d'une conversation téléphonique, on force manuellement la valeur à 1 le son sur l'écouteur du téléphone est en effet coupé (et dirigé sur les écouteurs mains libre si ils sont connectés. et vice versa.

En conclusion, le fait que cette valeur soit à "1" explique que tu n'entendes plus rien sur ton téléphone. Si cette variable est à 1 alors que les écouteurs ne sont pas branchés, la mettre à "0" est une solution de contournement provisoire mais qui est à aplliquer tant que la cause pour laquelle la valeur est à "1 sans écouteurs n'est pas solutionnée.....

Il y a trois raisons possibles à cette anomalie:
Un logiciel tiers affecte le fonctionnement normal d'un pilote de périphérique de l'ACER (en générant des événements incorrects insertions/retraits de prise jack par exemple).
Une manipulaiton a été faite dans la base de registre alterant le bon fonctionnement du pilote de l'ACER ou un autre pilote a été installé.
Un problème matériel rend les évènements de détection de la prise jack hasardeux... (faux contacts, etc).

C'est très étrange que la connection du téléphone au port USB du PC positionne HeadSetIn à "1"... Ce d'autant plus que, typiquement, sur le S200 on utilise pas le port USB pour brancher des écouteurs comme certain autres téléphones....

Cdlt,

PS/Edit:
L'etat de HeadSetin dans votre cas est donc la conséquence d'un autre problème.


Dernière édition par jpg1961 le Mer 20 Jan - 16:30, édité 1 fois
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Marvel
Petit posteur
Petit posteur


Messages : 23
Date d'inscription : 12/01/2010

MessageSujet: Re: Solution au probleme de son   Mer 20 Jan - 16:29

darky35 a écrit:
Ok !!!

La modif de base de registre ce fait lorsque vous branchez vos tel sur le pc avec le cable USB !!

mais es ce que vous etes en ActivaSync ou en mode lecteur de carte

merci de tester les 2 manip de connexion au pc et de verifier si le probleme arrive avec l'une ou l'autre connexion ou les 2 .......


Testé sur les deux positions (justement hier je me suis dit que ça pouvait venir de là) et même problème au final Evil or Very Mad



Salut jpg1961
Merci pour tes explications Wink
Dans mon cas, en reprenant ton post : :

Il y a trois raisons possibles à cette anomalie:
Un logiciel tiers affecte le fonctionnement normal d'un pilote de périphérique de l'ACER (en générant des événements incorrects insertions/retraits de prise jack par exemple).


Possible mais maintenant reste à trouver lequel !!!!

Une manipulaiton a été faite dans la base de registre alterant le bon fonctionnement du pilote de l'ACER ou un autre pilote a été installé.

Pas de manipulation de la base de registre hormis celle permettant de forcer cette clé HeadSetIn de 1 à 0

Un problème matériel rend les évènements de détection de la prise jack hasardeux... (faux contacts, etc).

Ce qui pourrait signifier qu'une série en sortie d'usine chez Acer pourrait avoir ce "bugg" vu que plusieurs personnes rencontrent ce problème.


Dernière édition par Marvel le Mer 20 Jan - 16:46, édité 2 fois
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
jpg1961
Méga posteur
Méga posteur


Messages : 201
Date d'inscription : 09/01/2010

MessageSujet: Re: Solution au probleme de son   Mer 20 Jan - 16:34

Marvel a écrit:
darky35 a écrit:
Ok !!!

La modif de base de registre ce fait lorsque vous branchez vos tel sur le pc avec le cable USB !!

mais es ce que vous etes en ActivaSync ou en mode lecteur de carte

merci de tester les 2 manip de connexion au pc et de verifier si le probleme arrive avec l'une ou l'autre connexion ou les 2 .......


Testé sur les deux positions (justement hier je me suis dit que ça pouvait venir de là) et même problème au final Evil or Very Mad

Hum... si tu as fait une restauration totale, reflashé la ROM et enlever la batterie du téléphone et que le problème persiste, cela laisse supposer qu'il y ait un problème hardware qui affecte le module de détection de connection/deconnection de prise jack et de prise USB (peut-être le même pilote d'ailleurs....).

Cdlt,
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
darky35
Méga posteur
Méga posteur


Messages : 671
Date d'inscription : 01/01/2010
Age : 45
Localisation : Bretagne

MessageSujet: Re: Solution au probleme de son   Mer 20 Jan - 16:43

Sinon un dernier petit test !!!

Brancher un autre casque, mettre un music et le debrancher ( sur ce coup je garantis rien du tout ) mais qui ne tente rien n'a rien au point ou on est rendu autant essayer le maximun de bidouille .

Allez a vos tel messieurs !!!
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
seb.c_38
Petit posteur
Petit posteur


Messages : 14
Date d'inscription : 18/01/2010
Localisation : Grenoble

MessageSujet: Re: Solution au probleme de son   Mer 20 Jan - 17:17

Salut jpg1961,

jpg1961 a écrit:

Bonjour,
Je voudrais faire quelques remarques et je te prie de ne pas les considerer comme une critique.

Toutes les critiques sont bonnes a prendre si elles sont contrutives !!

jpg1961 a écrit:

En l'occurence, ici, je crois que les termes "solutions" et "résolutions" ne sont pas adaptés. Crying or Very sad

...
la mettre à "0" est une solution de contournement provisoire mais qui est à aplliquer tant que la cause pour laquelle la valeur est à "1 sans écouteurs n'est pas solutionnée.....

En fait je voulais mettre 'workaround' mais n'ayant pas de traduction appropriee telle que 'contournement provisoire', j'ai opte pour 'solution' alors qu'avec le recul (ca plante toujours), ce n'est pas reellement une solution, mais un depanage de fortune utile.

jpg1961 a écrit:

L'etat de HeadSetin dans votre cas est donc la conséquence d'un autre problème.

Bien vu mais difficile a localiser a moins de decompier l'ensemble de la ROM ...

Pour tout le rest, je suis 100% ok :yes:

Seb.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
jpg1961
Méga posteur
Méga posteur


Messages : 201
Date d'inscription : 09/01/2010

MessageSujet: Re: Solution au probleme de son   Mer 20 Jan - 18:38

seb.c_38 a écrit:
Salut jpg1961,
[...]
Bien vu mais difficile a localiser a moins de decompier l'ensemble de la ROM ...
[...]

Seb.

Décomplier la ROM permet de comprendre avec plus de finesse quelles sont les modules qui touchent HeadSetIn, mais je ne suis pas vraiment certain que les conclusions que cela permettrait d'avoir serait à la hauteur de l'effort à fournir. Smile.

En fait, je suis même certain que cela soit la bone piste car:

- Ta ROM est quasiment stock et tu ne sembles pas vraiment avoir bidouillé ta machine avant de rencontrer le problème.
- Ce phénomène n'est reproduisible que sur un tout petit échantillon d'utilisateur (Pour la plus part des utilisateurs qui sur les forums parlent d'une perte de son sauf à passer par la prise jack ou un main libre, il semble bien que cela se solutionne par un retour SAV).

Cela milite dans la direction d'un problème matériel...

Question peut-être bête, mais après la reinitilisation complete, as-tu enlevé la batterie? C'est à mon sens, le seul moyen d'avoir un vrai "clear" de tout les circuits... Qui sait si le circuit de détection jack est pas dans les choux.... C'est tout de même fort de café que la prise USB déclenche un événement confondu avec l'insertion d'une prise jack....

Lorsque HeadSetIn est mis à "1" suite au branchement de l'USB, est-ce que après avoir débranché l'USB, connecté le kit main libre, puis déconneter ce même kit, HeadSetIn ne repasse pas à "0"?

Cdlt,
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
jpg1961
Méga posteur
Méga posteur


Messages : 201
Date d'inscription : 09/01/2010

MessageSujet: Re: Solution au probleme de son   Mer 20 Jan - 19:07

Marvel a écrit:
darky35 a écrit:
Ok !!!

La modif de base de registre ce fait lorsque vous branchez vos tel sur le pc avec le cable USB !!

mais es ce que vous etes en ActivaSync ou en mode lecteur de carte

merci de tester les 2 manip de connexion au pc et de verifier si le probleme arrive avec l'une ou l'autre connexion ou les 2 .......


Testé sur les deux positions (justement hier je me suis dit que ça pouvait venir de là) et même problème au final Evil or Very Mad

Cela tend à confirmer une hypothèse que le couple activesync/PC n'a rien avoir la dedans (ce qui n'est pas du tout surprenant), mais plutôt que le module logiciel (où le circuit électronique) générant les évenements de connexion de périphériquelève un événement qui pour une raison quelconque fait croire qu'il faut positionner HeadSetIn à "1" avec les conséquences que cela implique.


Marvel a écrit:

Salut jpg1961
Merci pour tes explications Wink
De rien, j'espère qu'elles n'étaient pas trop confuses Smile.

Marvel a écrit:

Dans mon cas, en reprenant ton post :
Il y a trois raisons possibles à cette anomalie:
Un logiciel tiers affecte le fonctionnement normal d'un pilote de périphérique de l'ACER (en générant des événements incorrects insertions/retraits de prise jack par exemple).


Possible mais maintenant reste à trouver lequel !!!!

Une manipulaiton a été faite dans la base de registre alterant le bon fonctionnement du pilote de l'ACER ou un autre pilote a été installé.
Pas de manipulation de la base de registre hormis celle permettant de forcer cette clé HeadSetIn de 1 à
0
J'évoquais les possibles causes de l'anomalie observée sur le comportement de HeadSetIn sans donner plus de crédit à l'une qu'à l'autre, je penche pour ma part plus pour un problème HW.
Et ce d'autant plus qu'à priori, tu n'aurais pas installé de logiciels susceptibles d'interagir à ce niveau ni fait de modificaitons remarquable sur la base de données.

Marvel a écrit:


Un problème matériel rend les évènements de détection de la prise jack hasardeux... (faux contacts, etc).

Ce qui pourrait signifier qu'une série en sortie d'usine chez Acer pourrait avoir ce "bugg" vu que plusieurs personnes rencontrent ce problème.

Absolument, on constate même des gens qui indiquent avoir utilisés pendant des jours sans problèmes leur téléphone et que dès la première insertion de la prise jack ont rencontré le problème.

Maintenant, problème de détection HW ne veux pas dire téléphone HS ou SAV obligatoire.... Il se peut que pour diverses raisons le circuit bas niveau sur la carte électronique du téléphone soit "bloqué".... Ré écraser la ROM ou réinitialisr la ROM en espérant une correction peut ne pas être suffisant pour "débloquer" le circuit.... Alors que le retrait de la batterie le ferait.... Bon, c'est jutse une hypothèse....

Parfois, retirer et remettre une jack quelque fois peu résoudre le problème si c'est purement une histoire de contact.... Mais dans ce cas, il faut s'attendre à ce que cela puisse se reproduire et déboucher un jour sur la panne complète au niveau de la prise jack.

Cdlt,
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
seb.c_38
Petit posteur
Petit posteur


Messages : 14
Date d'inscription : 18/01/2010
Localisation : Grenoble

MessageSujet: Re: Solution au probleme de son   Mer 20 Jan - 19:11

Jpg,

je va pas tout citer car je vais en avoir pour 2heures !!!

je n'ai pas retire la batterie apres le flash complet d'hier, mais je l'ai fait apres le hard reset de ce WE !!!

Si tu as un 'process' qui dit quand retirer la betterie, je suis preneur.
(style : Hard reset, apres 1er boot, eteindre le telephone, retirer la batterie, remettre en route).

Sinon, pour le test du casque.

1- met HeadSetIn = 0

2- Branche le casque
le son sort toujours du telephone (pas du casque).

3- reboot

4- le HeadSetIn est bascule a 1

2eme test:
1- met HeadSetIn = 1
2- reboot
3- HeadSetIn est reste a 1

Note : j'ai essaye entre 1 et 2 de brancher ou ne pas brancher le casque (le son sors bien du casque), le resultat est le meme.


A+

Seb.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
jpg1961
Méga posteur
Méga posteur


Messages : 201
Date d'inscription : 09/01/2010

MessageSujet: Re: Solution au probleme de son   Mer 20 Jan - 20:39

seb.c_38 a écrit:
Jpg,
je va pas tout citer car je vais en avoir pour 2heures !!!
Smile
Citation :

je n'ai pas retire la batterie apres le flash complet d'hier, mais je l'ai fait apres le hard reset de ce WE !!!
Ma foi, si cela avait été un problème de circuit "bloqué", je suppose que cela aurait été suffisant. Un hard reset et le retrait de la batterie ne sont pas necessairement des choses à relier entre elle.
Le retrait de la batterie à pour objet de s'assurer que l'alimentation des circuits électroniques a belle et bien été totalement interrompue, et que ainsi les circuits ont fait l'objet d'un reset comparable à une véritable mise hors tension. (sauf probablement le circuit horloge).

Citation :

Si tu as un 'process' qui dit quand retirer la betterie, je suis preneur.
(style : Hard reset, apres 1er boot, eteindre le telephone, retirer la batterie, remettre en route).
Celui que tu cites me semble très bien. Mais encore une fois, la corrélation avec une "restauraiton" de la ROM n'est pas indispensable. Les deux actions ne poursuivent pas tout à fait le même but.

Citation :

Sinon, pour le test du casque.

1- met HeadSetIn = 0

2- Branche le casque
le son sort toujours du telephone (pas du casque).

Ok, donc déjà il y a une anomalie.
HeadSetIn devrait passer à 1 et le son sortir du casque
Au fait on parle bien du dispositif main libre fourni avec le S200? Vu que c'est une prise jack 4 poles (Gauche, droite et micro).... faudrait pas compliquer les choses en utilisant des ecouteurs avec une prise jack 3 poles..... Smile.
Je suppose que si à ce moment tu forces HeadSetIn à 1, le son va sortir du casque....

Citation :

3- reboot

4- le HeadSetIn est bascule a 1
Et le casque qui était branché en 2 est toujours branché, donc à priori, ton S200 détecte la présence du kit main libre filaire au boot (chargement des pilotes), mais selon l'étape 2, ne détecte pas son insertion (transition d'état).

Citation :

2eme test:
1- met HeadSetIn = 1
2- reboot
Si le casque n'est pas branché, cette valeur est normalement remise à "0" au démarrage..... Sauf bien sur, si le tu as laissé ton port USB branché puisque tu as aussi cette anomalie là de fonctionnement :-).

Citation :

3- HeadSetIn est reste a 1
Ce qui ne devrait absolument pas être le cas si tu as débranché le casque...

Sur un S200 "normal". Chaque fois que tu branches ou débranches le casque, tu devrais voir basculer la valeur de HeadSetIn. (bon suivant le soft utilisé pour consulté le registre il faut peut-être faire une manip pour rafraichir la "vue".

Citation :

Note : j'ai essaye entre 1 et 2 de brancher ou ne pas brancher le casque (le son sors bien du casque), le resultat est le meme.

Lorsque HeadSetIn est à 1, c'est normal que le son sorte du casque, ce qui est anormal c'est que la valeur ne bascule pas.

Tout à l'heure, j'ai mis mon S200 hors tension, je l'ai démarré sans kit main libre, j'ai exporté la base de registre HKLM. Connecté le kit main libre et exporté à nouveau la base de registre. Comparé les résultat et Il y avait deux différences uniquement, la valeur de HeadSetIn passé à "1" et time dans system\state\hardware.... Ce qui est le résultat auquel on devait s'attendre.....

En dehors d'un problème dans l'interface jack.... Je seche......

PS: Je te suggère de supprimer l'entrée HeadSetIn...
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Contenu sponsorisé




MessageSujet: Re: Solution au probleme de son   Aujourd'hui à 12:38

Revenir en haut Aller en bas
 
Solution au probleme de son
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 3Aller à la page : 1, 2, 3  Suivant
 Sujets similaires
-
» [avis] solution au probleme de captation.
» [RESOLU] Rendu des photo Contact qui diminue.
» [ Aligner Ecran ]
» photo fun studio 8.3
» [IGO8] probleme résolution écran

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Acer newTouch :: Problèmes :: Matériels-
Sauter vers: